Introduction

Create a new application

The DataWeb Designer

Display Data in a View

Customize Your View

Add a Lookup Field

Modify the Application Template

Change Security Settings

Create a Nested Data Region

Conclusion



Home > Support

DataWeb Tutorial


The DataWeb Designer

Objectives:

  • Explore the parts of the DataWeb Designer
  • Learn about the common types of files that make up your application.

Estimated Time to Complete: 10 minutes

Skill level: Beginner



The Edit Page link appears on your application only for those to whom you have granted design privileges.
You can modify the design of your application with the DataWeb Designer. The DataWeb Designer runs in your web browser; you don't have to install any additional software to use it.


Editing Your Application in the DataWeb Designer
If you're viewing your new application as we did in the previous section, you can click the Edit Page link in the top left corner of the page to display your application in the DataWeb Designer. You can also navigate to the My Webs page and select your application from the list.

A Tour of the DataWeb Designer
Next we'll review the various parts of the DataWeb Designer, so that you become familiar with it. Feel free to experiment as we address each part. Listed below are some of the parts of the Designer that you’ll want to learn about.



Start Page
The Start Page is a convenient place from which to modify and manage your application. You'll also find pointers to useful information about working with the DataWeb Designer here. You select Start Page from the View menu.

Menu Bar
At the top of the Designer, you'll see the menu bar.

*Try clicking on the various menus now to see the commands they offer.

Designer Tabs
The Designer Tabs is the tool that you use to modify your web application. Some of the things you can do within the Designer include: Build data tables to store your data. Data tables form the backbone of your web application. Create views for displaying, inserting, updating, and deleting data. Together the views in your web application form what your users will see when they visit your site. Write scripts to customize your web application.

File Directory
In the left-hand side of the Designer, you'll see the file directory. The file directory shows all of the files and folders in your application. Files and folders are arranged hierarchically -- folders can contain files and subfolders, subfolders can contain other files and subfolders, and so on. The top folder (or root folder) represents your application itself.  

*Click on the folders and files in the file directory now to see how it works. You should see the Books folder in the list. This is the folder that's associated with the Books table you created in the previous section. Every data table in your application lives within a folder in the file directory.

Work Area
The work area is where you modify the files and folders in your application. Try clicking on different files to display them in the work area.

Properties Pane
The Properties Pane is where you can modify the different elements that you place within a .view or .data file. Each element, whether it is a dataregion, an action bar, or an htmlblock, will display a characteristic set of properties that you can modify in the Properties Pane. To modify a given element, simply select it in the Work Area, and modify its properties in the Properties Pane. The image to the right shows the property pane for a data region. For more information about using the Properties Pane to modify your web application.



Types of Files in Your Application

Let's review some of the different types of files you will encounter in your DataWeb application.

Data tables
The data in your application resides in data tables. Data tables form the backbone of your DataWeb application.

When you add a new data table, the table is created within a data folder of the same name. Within the data folder, two new files are automatically created, a .data file and a default.view file. The .data file stores the schema information for the table, including its fields and data types, and shows a preview of the data in the table.   

The default.view file displays the data in your table. DataWeb views are discussed in the next section.

*Try clicking on the Books data folder now to see these files in your own web. Click on the Books.data file to preview your data, and click on the Design tab to see the fields in your table.

View files
A view file is a web page that acts as a window onto the data in your table. View files have the extension .view

You can customize a view file to display your data however you want. You can use a view to display your data as a grid or in details mode, or for inserting and updating data.

The DataWeb Designer makes it easy to modify view files graphically. The underlying source for a view file is simple HTML and XML, so you can also edit the view source directly if you prefer.

*Try clicking on the default.view file in the Books data folder now. Experiment by selecting the different elements of the view file. Notice that each selectable element has a set of properties in the Properties pane, which you can modify to change the element's characteristics.






 
Affiliate | Partner | Terms of Use | Privacy Policy | Contact Us | Pricing | Bring DataWeb In-House    
DataWeb, 720 North 10th Street, A #145, Renton, Washington 98057 *425-583-5970* Fax 484-770-4706* Email Us